LACP or other options

Cisco Flex links

Cisco FlexLinks offers linklevel redundancy. Normally, two switches can be hooked up with a channel (LACP/PAGP) however there are sometimes setups in which you cannot use a channeling protocol. If you cannot have the STP recalculation timers, FlexLinks might offer the solution.

On a FL enabled setup, STP is disabled on the backup interface. One of the interfaces is the primary interface, the other one is the backup.

Link 1 is active and link 2 is standby. If link 1 is disconnected, all traffic runs through link 2. A single ping is lost during the switchover. No effect on interactive transactions.

As soon as link 1 turns active, this link remains in standby, unless preemption is configured.

Below the snippets of the configs of both switches, in which only the relevant parts of the tested configurations is shown.

Good to know alternatives exist….


hostname switch01
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
interface FastEthernet1/0/1
switchport trunk encapsulation dot1q
switchport trunk native vlan 10
switchport trunk allowed vlan 10,20
switchport backup interface Fa1/0/48
switchport backup interface Fa1/0/48 mmu primary vlan 10
switchport backup interface Fa1/0/48 preemption mode forced
switchport backup interface Fa1/0/48 preemption delay 30
switchport mode trunk
!
interface FastEthernet1/0/48
switchport trunk encapsulation dot1q
switchport trunk native vlan 10
switchport trunk allowed vlan 10,20
switchport mode trunk
!
interface Vlan10
ip address 10.0.0.1 255.255.255.0
!
interface Vlan20
ip address 20.0.0.1 255.255.255.0
!
mac address-table move update transmit
end


hostname switch02
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
interface FastEthernet1/0/1
switchport trunk encapsulation dot1q
switchport trunk native vlan 10
switchport trunk allowed vlan 10,20
switchport backup interface Fa1/0/48
switchport backup interface Fa1/0/48 mmu primary vlan 10
switchport backup interface Fa1/0/48 preemption mode forced
switchport backup interface Fa1/0/48 preemption delay 30
switchport mode trunk
!
interface FastEthernet1/0/48
switchport trunk encapsulation dot1q
switchport trunk native vlan 10
switchport trunk allowed vlan 10,20
switchport mode trunk
!
interface Vlan10
ip address 10.0.0.2 255.255.255.0
!
interface Vlan20
ip address 20.0.0.2 255.255.255.0
!
mac address-table move update transmit
end

Comments are closed.